Rendre les extensions de Firefox compatibles

La fondation Mozilla a depuis quelque temps choisi d’augmenter le rythme des parutions des nouvelles versions du navigateur Firefox (FF). Ainsi, un mois après la sortie de la version 5.0, la version 6.0 est dans les tubes. Changer de version est très simple avec FF, cela se fait directement sans que vous ayez besoin de rechercher quoique ce soit. En revanche, pour les extensions la donne est différente.

firefox-logoCe qui fait la plus-value de FF par rapport aux autres navigateurs, et principalement de Chrome est la souplesse et la variété des modules complémentaires que vous pouvez installer. Seulement, ces extensions correspondent à une version du navigateur. Ce qui fonctionnait parfaitement sur la version précédente, peut poser des problèmes sur la nouvelle version, en tous cas le temps que les développeurs mettent à jour leur produit. Or, la comptabilité se fait parfois exclusivement sur le numéro de version du module, plutôt que sur le code. L’idéal serait donc de pouvoir éviter la vérification automatique de compatibilité; c’est ce processus qui désactive parfois vos extensions favorites.
Ce rythme des changements a de quoi agacer les utilisateurs assidus de FF, qui adoptent ce navigateur plutôt qu’un autre, parce qu’il existe des extensions qui correspondent précisément à leurs habitudes de surf. Et le fait de vouloir supprimer le numéro de version pour laisser la place à un programme en évolution permanente, à l’instar de Gmail, pourrait ne pas être suffisant.

Heureusement, il existe une extension très pratique, qui évite ce contrôle de compatibilité, et qui en prime, permet de faire remonter l’information de compatibilité à Mozilla. C’est Add-on Compatibility Reporter, et c’est développé justement par la fondation.

Add-on Compatibility Reporter

Une fois installé, il permet de désactiver le contrôle automatique des versions, et vous propose de valider vous-même la compatibilité. Dans la plupart des cas cela vous conviendra parfaitement sans risque de plantage, dans le cas contraire, soit le navigateur ne permettra pas à l’extension de s’exprimer (vous pourrez alors faire remonter l’info), soit plantera FF auquel cas vous pourrez alors redémarrer en mode sans échec puis désactiver l’extension considérée.

Add-on Compatibility Reporter 2

Par exemple avec la version 6.0 de FF,  l’extension Measureit 0.4.9 n’est a priori pas compatible. Or elle fonctionne parfaitement lorsque vous évitez le contrôle des versions grâce à l’add-on Compatibility Reporter.

Laisser une réponse:

Votre adresse mail ne sera pas publiée.

Notifiez-moi des commentaires à venir via email. Vous pouvez aussi vous abonner sans commenter.

Pied du site

Barre latérale coulissante